Routing on Cisco Cli

עודכן ב: אוג 10

איך עושים ניתוב בסיסקו


מה זה ROUTING :

ניתובאנגלית: Routing) פירושו קביעת דרך, מסלול, למעבר של מידע וחבילות נתונים ממקום למקום ברשתות תקשורת נתונים - במצבים שבהם אין קו תקשורת ישיר בין נקודת השליחה לנקודת היעד. לדוגמה, ברשת האינטרנט, מכיוון שבדרך כלל אין קו תקשורת ישיר בין נקודות המוצא והיעד, יש צורך להשתמש ב"שרשרת" של תחנות ביניים שיקבלו את המידע מהתחנה הקודמת ויעבירו הלאה לתחנה הבאה, הניתוב מסמל את הדרך ותחנות התקשורת השונות שבהם יעברו הנתונים מנקודת המוצא\שליחה עד לנקודת היעד.

אחת המטרות העיקריות בפיתוח תחום ניתוב הנתונים היא אוטומציה של התהליך כדי ליצור רשתות אוטונומיות אשר יאפשרו שקיפות של תהליך ניתוב התקשורת. רשתות אוטונומיות מקדמות חבילת מידע בנתיב הטוב ביותר; ההחלטות מתקבלות בהתאם למטרות כמו מציאת נתיב קצר ביותר ומהיר ביותר בין כל אפשרויות ניתוב חבילת מידע ברשת. עקרון אוטומטיזצית הניתוב מאפשר לנתב תקשורת כך שתעקוף תקלות ברשת ואת "צווארי הבקבוק". אוטומציית הניתוב מקלה על שגרת תפעול הרשת ללא התערבות מצד בן אדם.


פה במאמר הזה אנחנו נראה שלושה דרכים לעשות ROUTING:

EIGRP

OSPF

RIP

IP ROUTE

יש לכם כאן קישור לשלושה מעבדות כדי להבין היטב את ROUTING

לחץ כאן

כאן אתם יכולים לראות מה זה ROUTING ואיך זה עובד


יש לי מחשב PC0 אם כתובת 192.168.0.100 ומחשב PC1 אם כתובת 10.10.10.10 כדי שהרוטר 0 ורוטר 1 ידעו לנווט אותי בין רשת .192.168.0.0 ל10.10.10.0 צריך להגדיר את הרוטר שיעבור ב172.16.0.1 ו172.16.0.2 אם לא 192.168.0.100 לא יוכל לתקשר עם 10.10.10.10 כי הרוטר R0 לא מכיר את הדרך להגיע 10.10.10 וההפך

IP ROUTE:

אז פה נראה 3 דרכים כדי לעשות ניתוב ברשת שלכם :



IGP = interior gateway Protocol

EGP = Exterior Gateway Protocol

הפרוטוקול EGP הוא פרוטוקול ניווט לאינטרנט כמו שחתום בשמו (Exterior )


The Exterior Gateway Protocol (EGP) is a routing protocol for the Internet originally specified in 1982 by Eric C. Rosen of Bolt, Beranek and Newman, and David L. Mills.[citation needed] Exterior Gateway Protocol (EGP) is a protocol for exchanging routing information between two neighbor gateway hosts (each with its own router) in a network of autonomous systems. EGP is commonly used between hosts on the Internet to exchange routing table information. The routing table contains a list of known routers, the addresses they can reach, and a cost metric associated with the path to each router so that the best available route is chosen. Each router polls its neighbor at intervals between 120 and 480 seconds and the neighbor responds by sending its complete routing table. EGP-2 is the latest version of EGP.


ופרוטוקול IGP הוא פרוטוקול נווט פנימי כאילו בטוח הארגון וכאן אנחנו נתמקד רק בIGP


OSPF:


Open Shortest Path Firstראשי תיבות: OSPF) הוא פרוטוקול ניתוב היררכי, תלוי מצב (Link-state) להעברת נתונים בין ראוטרים שונים הנמצאים באותה מערכת אוטונומית. בבסיס הפרוטוקול עומד אלגוריתם דייקסטרה, המשמש לחישוב עץ המרחק הקצר ביותר. OSPF משתמש בעלות העברת הנתונים (מספר המציין את גודל רוחב הפס) לצורך חישוב המרחק, ותמיד יבחר את הנתיב הזול ביותר להעברת חבילה מהמקור אל

היעד.


RIP:


Routing Information Protocol (בראשי תיבות: RIP) הוא פרוטוקול ניתוב המתבסס על ספירת צעדים (Hop Count) על מנת לבצע החלטות ניתוב.

נתב המשתמש ב־RIP מנהל רישום של כל הנתבים אותם הוא "מכיר", הרשתות המחוברות אליהן, וכמות הצעדים בכל נתיב לכל יעד. כאשר מגיעה חבילה אל הנתב הוא יעביר אותה בנתיב בו היא תעבור מינימום צעדים עד לרשת היעד, שיטה זו מכונה ספירת צעדים (hop count). הנתב מבקש עדכונים לגבי שינויים בטופולוגית הרשת מהנתבים המחוברים אליו כל שלושים שניות, וכך הוא נשאר מעודכן לגבי שינויים בנתיבים המובילים אל היעד, ומקבל מידע על נתבים חדשים שחוברו אל הרשת.



הפקודות ניתוב:

בציור ip route אתם יכולים לראות את כל פקודות הניתוב בRUNNING CONFIG


כדי להגיע ל10.10.10.0 אני צריך לעבור ב זה המשפט שצריך לא לשכוח בIP ROUTE

ip route 10.10.10.0 255.255.255.0 172.16.0.2


RIP:

router rip

version 2

passive-interface FastEthernet0/0 =רק במקומות שיש מחשב או שרת

network 10.0.0.0

network 192.168.0.0 ==== כאן אתם יכולים לראות את האגדרות של רוטר 5 יש לו שני רשתות שונות

no auto-summary



OSPF:


router ospf 10

router-id 2.2.2.2 =כל רוטר חייב להיות כתובת internal 1111 2222 3333 4444 55555

log-adjacency-changes

network 192.0.0.0 0.255.255.255 area 0 =כאן שני הקצוות של הרוטר שלכם או יותר ולא לשכוח את Area שלכם

זה אומר אם יש נגיד ארגון אם כמה קומות ואני רוצה לבדד את הניתוב של קומה 10 נגיד אז במקום AREA 0 יהיה לי AREA 1

network 172.0.0.0 0.255.255.255 area 0


bandwidth =כמה רוחב פס יש לי

זה אומר אם יש לי 2 אפשרויות שונות להגיע לX באיזה הפרוטוקול OSPF יבחר

הוא יבחר את הדרך אחי קצרה אם ברוטר Y יש לי 100Mb/s וב Z 10Mb/s

אז OSPF בזכות ההגדרה הזאות יבחר בדרך אחי מהירה שזה Y


Troubleshouting :

show ip ospf database

show ip protocols

debug ip ospf events

show ip route



router ospf 10

default-information originate =לעדכן את כל הרוטר מיד



EIGRP:

Interior Gateway Routing Protocolראשי תיבות: IGRP) הוא פרוטוקול ניתוב מבוסס וקטור מרחק (distance-vector) לרשתות אוטונומיות (autonomous system) שהומצא על ידי חברת סיסקו בסוף שנות השמונים.

IGRP הומצא על מנת להתגבר על החסרונות של RIP (מספר קפיצות (hop) מקסימלי, וניתוב על בסיס קריטריון אחד) שבאו לידי ביטוי בעיקר ברשתות גדולות ומסועפות. IGRP יכול להשתמש במספר קריטריונים לבחירת הנתיב המועדף, ביניהם - רוחב פס, אמינות, עומס וזמן השהייה. מנהל הרשת יכול לבחור במי מהקריטריונים להשתמש, ואיזה משקל לתת לכל אחד מהם בהחלטה על בחירת הנתיב וכך לוודא שכל חבילת נתונים תעבור בנתיב המועדף בכל זמן נתון. מספר הקפיצות המקסימלי (hop count) של חבילה המנותבת באמצעות IGRP הוא 255 (לעומת 15 ב-RIP).

router eigrp

network 192.168.1.0 255.255.255.0

network 10.10.10.0 255.255.255.0

no auto-sumary



variance 10=

אם יש לי 2 דרכים לעבור כאן בתמונה R1 וR2 מרוטר 4 ובFA4/0 הוא יותר מהיר יש לא bandwidth יותר גדול אז Variance מה שהוא אולך לעשות להעביר 10 פעמים יותר פקתות ב FA4/0 מאשר FA6/0 אם לא הוא יעביר רק פי שניים בFA4/0


Troubleshouting :

ip eigrp topology


ליצירת קשר ושירות טכנאי מחשבים בירושלים עד הבית חייגו – 0532104457


52 צפיות
R

© 2019 maestro