פקודות מתקדמות של CISCO CLI

הCLI הוא שורות פקודות כדי לתקשר אם SWITCH ו ROUTER של Cisco

פה אנחנו נראה פקודות שימושיות למתחילים בחומרת Cisco ולמי שרוצה לעבור את הסמכת CCNA

אז בוא נתחיל:

כאן אנחנו נשתמש בכלי שקוראים PAcket Tracer של CIsco לחץ כאן כדי להוריד:

כדי להשתמש בcli דובל קליק על switch or router וcli


show ip route =של רוטרROUTING TABLE כדי לראות את ה



מה זה VTP ?

הVTP הוא פרוטוקול שקיימת בSWITCH של CISCO שנותנת את האפשרות להעביר נתוני VLAN מSWITCH לSWITCH ללא צורך להגדיר כל SWITCH מחדש הVTP SERVER הוא הSWITCH היחיד שצריך להגדיר וכמובן לייצר VLAN בSWITCH הזה

הCLIENT הוא המקבל את כל ההגדרות של VLAN



vtp domain _nessandco.net

VTP SERVER = vtp password cisco

vtp version 2


show vtp status =כדי לראות את כל ההגדרות של VTP


vtp mode client

VTP CLIENT = vtp domain nessandco.net

vtp password cisco

interface _fast or giga

switchport mode dynamic desirable =זה אומר שאני מגדיר את הפורט שהוא מוכן VTP SERVER לקבל את המידע מה


vtp mode transparent =יעבור הVTP עליו SWITCH אבל אם אני מחבר עוד VTP הזה הוא לא יקבל את ההגדרות SWITCH זה אומר ה



הPORT SECURITY מחבר כתובת MAC לכל משתמש אם האקר ירצה לפרוץ פיזית בארגון וינסה להשתמש מהפורט הזה בגלל שאין לא את כתובת הMAC של המחשב הוא לא יצליח לגשת לרשת של הארגון וגם יכול להגן על Arp-Spoofing כאילו האקר משנה את כתובת הMAC של מחשב הקורבן ולוקח במקומו את הכתובת ועושה MITM

interface fast

switchport mode access

PORT SECURITY STATIC = switchport port-security maximum 1

switchport port-security mac-address 00-0E-A6-A7-63-F7

switchport port-security violation shutdown


show port-security interface fast

פורט SECURITY STATIC כאן אתם יכולים לראות שהכתובת הMAC של מחשב A מוגדר ואם משהו ירצה לשנות את כתובת הMAC של המחשב הזה אז הוא יעשה ShutDown


interface fast

switchport mode access

PORT SECURITY DYNAMIC = switchport port-security maximum 1

switchport port-security mac-address sticky

switchport port-security violation shutdown

mode sticky =MAC באופן אוטומתי ללא צורך לכתוב כל כתובת MAC לשמור את כתובות SWITCH נותן את האפשרות ל

כדי להפשר לי להתחבר מרחוק בSSH ברוטר או בSWITCH :


ip domain-name nessandco.net

ip ssh version 2

crypto key genarate rsa

1024

line vty 0 15

transport input ssh

username admin password cisco


show ip interaface brief=כדי לראות את IP הגדרות


interface range fastethernet 0/24 =כדי להגדיר את כל הכרטיסי רשת


פה אנחנו נלמד על פרוטוקול HSRP פרוטול HSRP הוא פרוטוקול כדי לעשות FAILOVER על ROUTER

אם יש לי ארגון של 1000 איש ההם אני ישים רק רוטר אחד ? כמובן שלו אני רוצה לעשות HIGH AVIABILLITY כדי שהרוטר שלי יהיה מגובה אז אני יתקין 4 רוטר כדי עם אחד קורס השני מגבה



הפרוטוקול הזה גם בוחר בעצמו (אם לא הגדרתי PRIORITY) מי יהיה הרוטר שלי שיהיה ACTIVE ומי הרוטר שיהיה PASSIVE

גם מה שיודע לעשות הפרוטוקול זה ליצר לי כתובת VIRTUAL שכל הרוטר שלי (4) יהיה מוגדרים אם אותו IP


interface fast

ip address 192.168.1.253 255.255.255.0

standby 1 ip address 192.168.1.254

no shut

37 צפיות
R

© 2019 maestro